My instrument display is dead - 6SpeedOnline - Porsche Forum and Luxury Car Resource

Aston Martin DB7, DB9, DBS, Vantage V8, Vanquish, and Classic models
Sponsored by:

My instrument display is dead

  #1  
Old 04-25-2014, 05:06 PM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
My instrument display is dead

Hi Friends,

when I left from work today, 2009 AM DB9 with 18K mile was working fine. stopped at a place, 5 minutes later when I left I noticed Instrument display was kind of dead, even though car was running it wont show nay speed, temperature (see attached image), radio wound not turn on, tehn once it turned on it would not turn off. then I have yellow triangle, orange ABS and Red brake sign which persisted. I feel like brake is working fine.

I came home and have connected car to OEM charger thinking it was kind of hot today and may be battery is low, but at the moment I am very nervous.

Input from fellow AM owners appreciated.

Has anyone had similar problem?

I have Innova 3030 OBD II reader would that work on 2009 AM DB9 to read the error code?
 
Attached Thumbnails Click image for larger version

Name:	2.jpg
Views:	230
Size:	827.8 KB
ID:	365853   Click image for larger version

Name:	20140425_171451.jpg
Views:	255
Size:	2.49 MB
ID:	365862  

Last edited by Wildcat1212; 04-25-2014 at 05:10 PM. Reason: attache images
  #2  
Old 04-26-2014, 07:33 AM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
I love this forum, so much information.

I did some more research, there is a video on you tube showing exact same problem and it is due to faulty CRM (convertible roof module).
Our site AM expert Irish07 has been helpful as usual.
according to his suggestion I disconnected CRM (which is located under driver side rear wheel (LH drive), after removing wheel, wheel liner cover, there is a rectangular black panel in roof with 4 screws, once removed, CRM comes down, its attached to the plate, remove 2 plugs very tight but just wiggle wiggle and pull them it will come out) all signs are gone except brake light is still on. ABS and yellow triangle is gone. Display works, shows RPM, temp, speed, Gears all.

I am not sure why red brake light is still on and how to remove it. My brake pads are new, brake fluid is full.
When I move Parking brake lever up and down I almost feel like its not doing anything.

any suggestions?
is it OK to drive around with no CRM module till I get anew one.
where to get CRM module except dealer?
Hi Irish07 I miss you please come back to site, so I can get more input from you.

Thanks.
 
  #3  
Old 04-26-2014, 09:26 AM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
Update 2
Dared to drive car without
CRM at all.
While driving at slow speed wiggled the parking brake handle up and diwn. First warning came on "hand brake is on" released parking brake and vola everything back to normal.
Will be locating CRM somewhere and then back in business. Fellow AM owner need it's not hard at all to replace it.

Hope this helps others too.
 
  #4  
Old 04-26-2014, 09:44 AM
IbisRider's Avatar
Registered User
Join Date: Nov 2012
Location: Pasadena, CA
Posts: 654
Rep Power: 48
IbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant futureIbisRider has a brilliant future
Well done.
This was the most informative single person discussion on the forum.

I hope I'm as resourceful if something strange comes up on mine.
 
  #5  
Old 04-26-2014, 09:50 AM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
Originally Posted by IbisRider View Post
Well done.
This was the most informative single person discussion on the forum.

I hope I'm as resourceful if something strange comes up on mine.
I will be glade to help out. I have even installed a car lift in my garage and I am only 90 miles from you.
 
  #6  
Old 04-26-2014, 11:41 AM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
These are the pictures of CRM I removed, where its located and seems like part number has changed. I call AM Tampa and they don't seem to be able to locate similar part number. So I sent them pictures will see.
 
Attached Thumbnails Click image for larger version

Name:	1.jpg
Views:	233
Size:	76.8 KB
ID:	366017   Click image for larger version

Name:	2.jpg
Views:	191
Size:	91.9 KB
ID:	366018   Click image for larger version

Name:	3.jpg
Views:	208
Size:	83.1 KB
ID:	366019   Click image for larger version

Name:	4.jpg
Views:	199
Size:	63.9 KB
ID:	366020   Click image for larger version

Name:	5.jpg
Views:	211
Size:	52.2 KB
ID:	366021  

  #7  
Old 04-26-2014, 12:07 PM
62Jeff's Avatar
Registered User
Join Date: Nov 2011
Location: Houston-ish
Posts: 354
Rep Power: 44
62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute62Jeff has a reputation beyond repute
I hope I never have this issue with my car but am thankful the resources here help me understand what I need to do if it does. My first reaction to your initial post last night was how similar your issues were to the issues in my 97 XK8, which in my case was caused by a faulty ABS module. Had it not been for your follow-up post, I was getting close to suggesting your ABS module might be suspect.
 
  #8  
Old 04-26-2014, 12:16 PM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
Originally Posted by 62Jeff View Post
I hope I never have this issue with my car but am thankful the resources here help me understand what I need to do if it does. My first reaction to your initial post last night was how similar your issues were to the issues in my 97 XK8, which in my case was caused by a faulty ABS module. Had it not been for your follow-up post, I was getting close to suggesting your ABS module might be suspect.
Jeff,

I looked up inside the module its basically capacitors, resistors and circuits like computer mother board. SO with exposure to heat its just matter of time before it will fail. Its amazing someone had posted video of exact same problem.
it scares the hell out of one driving a car, when suddenly every thing is blank, nothing on display. I almost fainted, first reaction tested brakes and steering to If I can still control the car. I was at 20-30 MPH, but think about it if it happens at 70-80-90 MPH. lets admit we do drive at 90-100 MPH being AM owners.
 
  #9  
Old 04-26-2014, 07:54 PM
Registered User
Join Date: Jul 2012
Location: Knoxville, TN
Posts: 47
Rep Power: 8
RichKnox is on a distinguished road
Any component that pulls the CAN-BUS down can cause this. My Bluetooth Module likes to kill everything sometimes.
 
  #10  
Old 05-26-2014, 06:11 PM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
Got new CRM installed, had to take it to dealer to program it. Labor was $80 only though first they wanted $150 but other (Orlando) dealer quoted 80 so Tampa dealer matched the price.




Everything works now. Except now rear windshield seal has been broken, so need it to be glued back by someone.
 
  #11  
Old 05-26-2014, 06:51 PM
Registered User
Join Date: May 2013
Location: Glendale, CA
Posts: 432
Rep Power: 28
Bleen is a glorious beacon of lightBleen is a glorious beacon of lightBleen is a glorious beacon of lightBleen is a glorious beacon of lightBleen is a glorious beacon of lightBleen is a glorious beacon of light
I imagine this is only an issue on convertible cars?
 
  #12  
Old 05-26-2014, 09:32 PM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
Yes I think only volante, they have canvas to which glass is glued.
 
  #13  
Old 05-26-2014, 09:46 PM
karlfranz's Avatar
Registered User
Join Date: Apr 2011
Location: Melbourne
Posts: 2,370
Rep Power: 205
karlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond reputekarlfranz has a reputation beyond repute
I think Bleen was asking if the issues with the dash only affected convertibles, since the coupes don't have a CRM.
 
  #14  
Old 05-26-2014, 10:31 PM
Registered User
Thread Starter
Join Date: Aug 2013
Location: Ocala, fl
Posts: 387
Rep Power: 25
Wildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of lightWildcat1212 is a glorious beacon of light
Originally Posted by karlfranz View Post
I think Bleen was asking if the issues with the dash only affected convertibles, since the coupes don't have a CRM.
Lol, yes I got it now. Thank karlfranz
 
  #15  
Old 05-31-2014, 02:08 AM
Registered User
Join Date: May 2014
Location: San Diego
Posts: 1
Rep Power: 0
JayK is on a distinguished road
This just happened to my Vantage and was wondering where you purchased the CRM from and how much you gave for it?
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: My instrument display is dead


Join 6SpeedOnline
Visit our Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.