Go Back  6SpeedOnline - Porsche Forum and Luxury Car Resource > British > Bentley
Reload this Page >

Battery Changed Still Get Low Battery+electronics not working.

Notices
Bentley From the original 3 Litre to the current Continental GT and Mulsanne

Battery Changed Still Get Low Battery+electronics not working.

 
  #1  
Old 02-17-2019, 08:29 PM
Registered User
Thread Starter
Join Date: Feb 2019
Age: 23
Posts: 3
Rep Power: 0
08gtspeed is an unknown quantity at this point
Exclamation Battery Changed Still Get Low Battery+electronics not working.

Hey guys!

I recently purchased a 2008 Bentley Continental GT Speed and a few days later I got a low battery warning please start engine warning. I thought okay it must have been standing for a while waiting to be sold at the dealer. I followed the instructions posted on this forum and changed both rear batteries. However, I am still getting the same warning every time I start the car with the new Interstate batteries. Also, after I changed the batteries the seat adjustment on both sides stopped working, volume control does not work, telescopic steering stopped working and can't even adjust the side mirrors.

The car starts fine, runs fine but every time I start it up the clock resets and the profile changes I made get reset as well. I don't know if this helps but the key only works after I get out of the car to lock or unlock. Otherwise, I have to open the vehicle manually and when I do lock it using the key it the alarm goes off for about 10-20 seconds and then turns off.

I have been doing a lot of searching but unable to find an answer to this issue if anyone has already made a post about this I apologize and hope someone can point me in the right direction.

Thank You!
 
  #2  
Old 02-18-2019, 06:25 AM
Registered User
Join Date: Jan 2019
Location: Chicago, IL
Age: 57
Posts: 40
Rep Power: 0
Samhain is an unknown quantity at this point
Despite the new batteries it sounds like a weak LH battery to me.
 
  #3  
Old 02-18-2019, 07:40 AM
Registered User
Join Date: Dec 2010
Location: virginia
Posts: 137
Rep Power: 14
BentleyF is on a distinguished road
i agree the left battery is bad..
 
  #4  
Old 02-18-2019, 08:40 AM
Registered User
Thread Starter
Join Date: Feb 2019
Age: 23
Posts: 3
Rep Power: 0
08gtspeed is an unknown quantity at this point
Lightbulb Interstate MTP-49-H8

Thank you for your replies!

The battery I installed is an Interstate MTP-49-H8 with 730CCA and 910 cranking amps (https://www.interstatebatteries.com/products/mtp-49-h8). I will try getting a more powerful battery and see how it goes.

 
  #5  
Old 02-18-2019, 09:24 AM
Registered User
Join Date: Feb 2018
Location: Wisconsin
Age: 61
Posts: 305
Rep Power: 14
1eapplebaum is on a distinguished road
Hello,
It's not the power of the battery. They discharge the same amount "12v", some have more storage. Check your terminals for cleanliness and tightness, right and left side batteries.

Perhaps a mickeyed battery? By the way the book recommends an AGM battery. However that difference won't affect the current problem.
 
  #6  
Old 02-18-2019, 12:49 PM
Registered User
Join Date: Jan 2019
Location: Chicago, IL
Age: 57
Posts: 40
Rep Power: 0
Samhain is an unknown quantity at this point
Sometimes the batteries are bad when you get them. And these cars are very sensitive to bad LH batteries. Last 'new' OEM battery I got for my Phaeton at the dealer lasted less than a year.
 
  #7  
Old 05-10-2019, 09:37 AM
Registered User
Join Date: May 2019
Location: London
Posts: 28
Rep Power: 0
Engine is an unknown quantity at this point
Bit late to the party, but what spec is your vehicle, there are a few naughty systems in Bentley's that need periodically resetting otherwise they can continue to drain battery (even after a power disconnect)
 
  #8  
Old 05-16-2019, 03:03 PM
Registered User
Thread Starter
Join Date: Feb 2019
Age: 23
Posts: 3
Rep Power: 0
08gtspeed is an unknown quantity at this point
Hey! thank you guys for helping out with the issue. I was able to get the battery changed from the dealer and the car works perfect, I got battery tenders and usually attach them when the car will be sitting for more than a day or two.

However sometimes I still get the low battery sign once in a while although there are no other effects or warnings once I start the car, it only comes on when the ignition is on.

The car is 2008 GT Speed I don't think there is any other spec or special edition- but I could be wrong about that.
 
  #9  
Old 05-16-2019, 03:53 PM
Registered User
Join Date: Feb 2018
Location: Wisconsin
Age: 61
Posts: 305
Rep Power: 14
1eapplebaum is on a distinguished road
There is a low battery warning when the remote key needs a new battery. Probably not the case but worth a check.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Grey Goose
997 Turbo / GT2
5
03-08-2017 04:27 PM
Talisman013
997 Turbo / GT2
14
10-25-2016 09:08 AM
simpleman325i
Cayenne 955/957
26
09-17-2016 03:51 PM
Winnilaker
997 Turbo / GT2
6
02-24-2012 06:40 AM
secretvampire
996 Turbo / GT2
14
12-21-2009 06:04 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Battery Changed Still Get Low Battery+electronics not working.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.