Notices
997 2005-2012 911 C2, C2S, C4, C4S, GTS, Targa and Cabriolet Model Discussion.
Sponsored by:

"check engine" light is on.. need some help.

 
  #1  
Old 11-12-2006, 11:33 PM
Studio.73's Avatar
Registered User
Thread Starter
Join Date: Aug 2006
Location: New Jersey
Posts: 31
Rep Power: 14
Studio.73 is on a distinguished road
"check engine" light is on.. need some help.

I have 06 C4S w/ tiptronic and started some mods. I installed EVO V-flow intake 2 weeks ago and installed AWE headers, cat. converters and TUBI mufflers last Moday.
But, suddenly the "check engine" light went on while I was driving on a highway and the engine feels little bit shaky when speed up from low RPM.

My friend told me that AWE exhaust products are made only for 6 speed manual transmissions,,, is that true?

Anyone has same experience or knows why I'm having check engine light?
 
  #2  
Old 11-13-2006, 09:37 AM
neil.schneider's Avatar
Registered User
Join Date: Jun 2004
Location: New Jersey(outside Phila)
Age: 58
Posts: 2,580
Rep Power: 119
neil.schneider has a spectacular aura aboutneil.schneider has a spectacular aura about
Can't the evo intake play havoc with some sensor and cause the check engine light to come on? What did the guys say who sold you the stuff.
 
  #3  
Old 11-13-2006, 09:39 AM
Evolution MotorSports's Avatar
Basic Sponsor
Join Date: Aug 2003
Location: AZ
Posts: 2,302
Rep Power: 520
Evolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond reputeEvolution MotorSports has a reputation beyond repute
Check the codes and lets us know. This is the only way to know for sure with out speculating.
 
__________________
Evolution MotorSports | www.evoms.com
EVOMSit - intelligent tuning |www.evomsit.com
P: 480.317.9911
F: 480.317.9901
E: [email protected]
Home of the Worlds Fastest 997TT Porsche(s)
997TT Standing Mile = 234.6 MPH
997TT Standing 1/2 Mile = 217.09 MPH
Fastest 1/4 Mile = 9.29 @ 172.7 MPH
60-130 MPH Time = 3.28 Seconds
  #4  
Old 11-13-2006, 11:06 AM
mdrums's Avatar
Registered User
Join Date: Jul 2006
Location: Tampa
Posts: 3,840
Rep Power: 228
mdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond reputemdrums has a reputation beyond repute
I bet it is the new cat converters. If they are 100 cell then that might be your problem. Make sure the MAF sensor was not damaged or dirty from the evo cold air intake install.
I have a c2s tip also and have never heard of any exhaust products just for 6 speeds.
 
  #5  
Old 11-13-2006, 12:22 PM
djantlive's Avatar
Registered User
Join Date: Oct 2004
Location: SFBA
Posts: 6,804
Rep Power: 338
djantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond reputedjantlive has a reputation beyond repute
What does your dash warning say? It should tell you if it's the MAF sensor. If so, I'd have the MAF sensor changed but if you want warranty to cover it, you'll have to return the intake to stock at least. can't imagine why cat and catback would throw CEL unless you are now running seriously lean or if 02 sensor is fouled or loose.
 
  #6  
Old 11-13-2006, 08:27 PM
Studio.73's Avatar
Registered User
Thread Starter
Join Date: Aug 2006
Location: New Jersey
Posts: 31
Rep Power: 14
Studio.73 is on a distinguished road
The dash warning says "check engine. Visit work shop".
I'm going to dealer tomorrow and will find out what is wrong.
 
  #7  
Old 11-14-2006, 01:09 AM
synergy's Avatar
Registered User
Join Date: Jun 2004
Location: San Jose, CA
Posts: 862
Rep Power: 56
synergy is a splendid one to beholdsynergy is a splendid one to beholdsynergy is a splendid one to beholdsynergy is a splendid one to beholdsynergy is a splendid one to beholdsynergy is a splendid one to beholdsynergy is a splendid one to behold
I have the AWE headers, AWE cats and AWE mufflers along with the EVO intake and now CEL problem thus far (6 months and no issue). Your problem might be with the Tubi mufflers.
 
  #8  
Old 11-14-2006, 12:51 PM
Josh/AWE's Avatar
Basic Sponsor
Join Date: Jul 2003
Location: Horsham, PA
Posts: 6,500
Rep Power: 343
Josh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond reputeJosh/AWE has a reputation beyond repute
Originally Posted by Studio.73
My friend told me that AWE exhaust products are made only for 6 speed manual transmissions,,, is that true?

Studio-

This is untrue. Our system is for both manual and auto cars.

Please keep us posted. To mirror what everyone else is saying, please read the codes and let us know what they are.

Thanks!
 
__________________
Josh Davis > Performance Specialist
AWE-Tuning.com > 1.888.565.2257
my email > facebook > twitter > instagram > youtube
  #9  
Old 03-06-2008, 04:06 AM
frafoss's Avatar
Registered User
Join Date: Feb 2007
Location: Norway
Age: 47
Posts: 382
Rep Power: 28
frafoss is on a distinguished road
Originally Posted by Studio.73 View Post
I have 06 C4S w/ tiptronic and started some mods. I installed EVO V-flow intake 2 weeks ago and installed AWE headers, cat. converters and TUBI mufflers last Moday.
But, suddenly the "check engine" light went on while I was driving on a highway and the engine feels little bit shaky when speed up from low RPM.

My friend told me that AWE exhaust products are made only for 6 speed manual transmissions,,, is that true?

Anyone has same experience or knows why I'm having check engine light?
Interested to know if you have fixed your problem and with what solution.
I have the X51 airbox, RSS plenum, Suncoast headers and FVD muffers, and as you got the CEL and the engine feels little bit shaky when speed up from low RPM and decrease to low RPM.

Thanks
 
  #10  
Old 03-06-2008, 05:39 AM
propr`one's Avatar
Registered User
Join Date: Mar 2008
Location: Around
Posts: 154
Rep Power: 18
propr`one is on a distinguished road
guys, OBD-2 scanners are rediculously cheap, they work for all 96+ cars.

ebay "c-reader" is the one i have, 35 bucks with shipping. it will tell you which code your ECU threw (and clear it if you like).

I like having it in the car so you know if its a small problem (o2 sensor acting up), or knocking/misfiring (i can't think of anything more subtle that you wouldn't notice but could cause damage.)
 
  #11  
Old 03-06-2008, 05:47 AM
frafoss's Avatar
Registered User
Join Date: Feb 2007
Location: Norway
Age: 47
Posts: 382
Rep Power: 28
frafoss is on a distinguished road
Originally Posted by propr`one View Post
guys, OBD-2 scanners are rediculously cheap, they work for all 96+ cars.

ebay "c-reader" is the one i have, 35 bucks with shipping. it will tell you which code your ECU threw (and clear it if you like).

I like having it in the car so you know if its a small problem (o2 sensor acting up), or knocking/misfiring (i can't think of anything more subtle that you wouldn't notice but could cause damage.)
Where did you get yours?
 
  #12  
Old 03-06-2008, 10:34 AM
Maddog78's Avatar
Registered User
Join Date: Feb 2008
Location: BC
Posts: 69
Rep Power: 14
Maddog78 is on a distinguished road
One example. Check ebay, there are others.
I don't know which one is "best" exactly.


http://cgi.ebay.com/ebaymotors/OBD2-...spagenameZWDVW



Here are some more.

http://www.nextag.com/obd2-scanner/search-html
 
  #13  
Old 03-06-2008, 12:45 PM
Registered User
Join Date: Nov 2005
Location: South FL
Age: 36
Posts: 52
Rep Power: 16
Floppy is on a distinguished road
Definitely check why the CEL is on. Diagnostic wise I would always go with Durametric ( http://fvd.us/us/en/Porsche-0/-/-/-/...iagnostic.html). There is nothing better unless you are planning on spending the big bucks.
 
  #14  
Old 03-06-2008, 05:47 PM
rah79's Avatar
Registered User
Join Date: Oct 2007
Location: NoVa
Posts: 503
Rep Power: 32
rah79 is on a distinguished road
I also have the full AWE system on and I got the CEL a few weeks back and its on and off. It states "Inefficiency banks 1 & 2" for Cats. I'm not sure now that I think of it if I have 200 CEL cats or 300. I also read on this forum that if I have the older CATS this might happen, and may need to be replaced.

Studio73 - Where in NJ are you? I also got black/black w/tip
 
  #15  
Old 03-06-2008, 06:27 PM
frafoss's Avatar
Registered User
Join Date: Feb 2007
Location: Norway
Age: 47
Posts: 382
Rep Power: 28
frafoss is on a distinguished road
Thanks for great help.

Is it correct that the CEL can disappear if everything is ok after a while? If so, is it after a certain amount of engine starts?
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: "check engine" light is on.. need some help.


Join 6SpeedOnline
Visit our Sponsors

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.