Notices
Aston Martin DB7, DB9, DBS, Vantage V8, Vanquish, and Classic models

Premium Sound system issues

 
  #1  
Old 02-27-2016, 06:01 AM
ArtB's Avatar
Registered User
Thread Starter
Join Date: Sep 2013
Location: Missouri USA
Posts: 221
Rep Power: 16
ArtB is a jewel in the roughArtB is a jewel in the roughArtB is a jewel in the rough
Premium Sound system issues

Anyone have or had experience with their premium sound system in the 2006 era Vantages have intermittent sound quality and cutting out issues? I think my amplifier(s) may be either loose, or on the fritz. If I brake very hard from speed, stereo will cut out or I will lose the drivers rear speaker sound. Sometimes the whole system will cut out completely. Where is the amp located? I would at least like to check the inputs and outputs to see if there are loose connections or bad wires before I start replacing speakers that sound fine most of the time.
 
  #2  
Old 02-27-2016, 06:39 AM
Registered User
Join Date: Sep 2009
Location: Bucks County, PA
Posts: 646
Rep Power: 45
mkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud of
I've read this issue before on piston head, and also experience the same myself before on the standard audio. According to PH, they said if you stomp / kick the passenger side footwell it will knock the audio back, and that is due to a badly designed component in the fuse box in the footwell. Let me find the thread for you so you can see if its the same issue:

http://www.pistonheads.com/gassing/topic.asp?t=974804
 
  #3  
Old 02-27-2016, 07:11 AM
Registered User
Join Date: Apr 2009
Location: NoVa
Posts: 4,386
Rep Power: 289
telum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond repute
  #4  
Old 02-27-2016, 08:23 AM
911MTB's Avatar
Registered User
Join Date: Apr 2012
Location: Ontario, Canada
Posts: 246
Rep Power: 16
911MTB will become famous soon enough
I've had this issues for years and I would just sharply raise the volume up and down and the front left speaker would start working again. Those links are great, it would seem it is a somewhat common problem and now I finally have an idea of how to fix it. I've already replaced the speaker and that did not make a difference. Thanks for posting the links!
 
  #5  
Old 02-27-2016, 08:37 AM
Registered User
Join Date: Apr 2009
Location: NoVa
Posts: 4,386
Rep Power: 289
telum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond repute
Lol I do the same thing... crank the volume for a split second to "shock" it back into action. I've been meaning to get it fixed properly but forgot about it since I've barely driven the car since winter started.
 
  #6  
Old 02-27-2016, 09:25 AM
Registered User
Join Date: Sep 2009
Location: Bucks County, PA
Posts: 646
Rep Power: 45
mkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud ofmkzhang has much to be proud of
Yes, thanks for finding the link I meant to find, but got too lazy
 
  #7  
Old 02-27-2016, 01:03 PM
ArtB's Avatar
Registered User
Thread Starter
Join Date: Sep 2013
Location: Missouri USA
Posts: 221
Rep Power: 16
ArtB is a jewel in the roughArtB is a jewel in the roughArtB is a jewel in the rough
Thanks guys! Anyone know if the new switching relay is available? Also, my car does not have Bluetooth, does that really matter. Would love to resolve this issue!
 
  #8  
Old 02-27-2016, 04:12 PM
Registered User
Join Date: Oct 2015
Location: USA
Posts: 350
Rep Power: 25
Jeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to behold
The switching relay is readily available - I replaced mine in October - but if you don't have Bluetooth I would check to see if you even have the module before buying a new one. It's easy to pull up the carpet and remove the cover plate to see.

The floor-stomping exercise should reveal if the problem is the switcher or something else.
 
  #9  
Old 02-27-2016, 07:08 PM
ArtB's Avatar
Registered User
Thread Starter
Join Date: Sep 2013
Location: Missouri USA
Posts: 221
Rep Power: 16
ArtB is a jewel in the roughArtB is a jewel in the roughArtB is a jewel in the rough
Originally Posted by Jeff_335i View Post
The switching relay is readily available - I replaced mine in October - but if you don't have Bluetooth I would check to see if you even have the module before buying a new one. It's easy to pull up the carpet and remove the cover plate to see.

The floor-stomping exercise should reveal if the problem is the switcher or something else.
Ok, great! I will pull up the floor mat and plate tomorrow and see if I have the relay. Would be great to get the system sounding perfect again!
 
  #10  
Old 02-28-2016, 10:26 AM
embdenb's Avatar
Registered User
Join Date: Sep 2015
Location: Florida
Age: 74
Posts: 658
Rep Power: 35
embdenb is a name known to allembdenb is a name known to allembdenb is a name known to allembdenb is a name known to allembdenb is a name known to allembdenb is a name known to all
Originally Posted by Jeff_335i View Post
The switching relay is readily available - I replaced mine in October - but if you don't have Bluetooth I would check to see if you even have the module before buying a new one. It's easy to pull up the carpet and remove the cover plate to see.
.
Readily available from whom? Aston Martin dealers?
 
  #11  
Old 02-28-2016, 11:29 AM
Registered User
Join Date: Oct 2015
Location: USA
Posts: 350
Rep Power: 25
Jeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to behold
I got mine from Lake Forest Sports Cars near Chicago. They had to order it from England so it took a few days. The new module looks different than the old green one.
 
  #12  
Old 02-28-2016, 11:39 AM
Registered User
Join Date: Apr 2009
Location: NoVa
Posts: 4,386
Rep Power: 289
telum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond reputetelum01 has a reputation beyond repute
Originally Posted by Jeff_335i View Post
I got mine from Lake Forest Sports Cars near Chicago. They had to order it from England so it took a few days. The new module looks different than the old green one.
thanks for the info - need to order one, too. good to know there's an updated unit, hopefully it works better!
 
  #13  
Old 02-28-2016, 12:20 PM
Registered User
Join Date: Oct 2015
Location: USA
Posts: 350
Rep Power: 25
Jeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to behold
Originally Posted by telum01 View Post
thanks for the info - need to order one, too. good to know there's an updated unit, hopefully it works better!
My car has Premium Sound and factory Bluetooth. The speakers in the front doors would cut in and out. The center and rear speakers worked fine. I found the Pistonheads thread and stomped on my passenger-side floor, and the front speakers worked for a while, then cut out. Stomped on the floor again, and the speakers worked again. I looked under the floor and there was the old green box for the switching unit. LFSC sent me a new switching unit for no charge, since I had recently purchased my car from them. So I'm not sure how expensive the new switcher is. But it definitely solved my audio problems, everything has worked perfectly for months now.

The old unit is a green metal rectangular box with a wiring harness that comes out of one end. The new unit is a black plastic rectangular box with wires coming out of two ends. It is an easy fix, I just left the failed old box in place and plugged in the new one above it. There is tons of room behind the access panel in the floor, and getting the old unit out seemed like a lot of work for nothing.
 
  #14  
Old 02-28-2016, 06:08 PM
ArtB's Avatar
Registered User
Thread Starter
Join Date: Sep 2013
Location: Missouri USA
Posts: 221
Rep Power: 16
ArtB is a jewel in the roughArtB is a jewel in the roughArtB is a jewel in the rough
Well, I pulled my floor plate up and to my dismay, there is no switching relay, I assume because I do not have Bluetooth. I looked around inside the relay panel to see if there are any loose wires but nothing.
 
  #15  
Old 02-28-2016, 06:27 PM
Registered User
Join Date: Oct 2015
Location: USA
Posts: 350
Rep Power: 25
Jeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to beholdJeff_335i is a splendid one to behold
Originally Posted by ArtB View Post
Well, I pulled my floor plate up and to my dismay, there is no switching relay, I assume because I do not have Bluetooth. I looked around inside the relay panel to see if there are any loose wires but nothing.
I just re-read your original post and if your back speakers are cutting out then even if you have Bluetooth it is not the problem. The Bluetooth switcher only affects the speakers in the doors.

If the whole system cuts out then the problem lies somewhere that affects everything. Unfortunately I couldn't tell you where to begin to look.

There's a guy in the UK who's posted a lot on Pistonheads and who seems to know more about these audio systems than even the engineers at Aston Martin. His name is James Hawkes-Reed and he works at a company called trackaphone, maybe you can find a way to contact him either through trackaphone or on Pistonheads where I believe his username is "trackaphone".
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Premium Sound system issues


Join 6SpeedOnline
Visit our Sponsors

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.