Notices
Bentley From the original 3 Litre to the current Continental GT and Mulsanne

Hazard Warning Lights Not Working

 
  #1  
Old 04-24-2019, 01:13 PM
DAV3's Avatar
Registered User
Thread Starter
Join Date: Apr 2019
Location: Warwickshire
Age: 32
Posts: 11
Rep Power: 0
DAV3 is an unknown quantity at this point
Exclamation Hazard Warning Lights Not Working

Hello all,

My hazard lights / switch isn't working on my Bentley Continental (2006).

Just wondering if anyone has encountered this before?

I have done a VCDS scan with no faults, just wondering if it may be the switch, or is there a relay?

Couldn't see anything mentioned in the owners / service manual and I have checked all the trunk / steering wheel fuses and all check out ok.

The flasher doesn't work with or without ignition on and the indicators / lock unlock work with flashing lights just fine.

I'm thinking switch, but would be great if someone else had similar issue?

Any help would be much appreciated !
 
  #2  
Old 04-24-2019, 03:19 PM
Rico.Adams's Avatar
Registered User
Join Date: Apr 2018
Location: England
Age: 54
Posts: 337
Rep Power: 0
Rico.Adams is an unknown quantity at this point
Originally Posted by DAV3 View Post
Hello all,

My hazard lights / switch isn't working on my Bentley Continental (2006).

Just wondering if anyone has encountered this before?

I have done a VCDS scan with no faults, just wondering if it may be the switch, or is there a relay?

Couldn't see anything mentioned in the owners / service manual and I have checked all the trunk / steering wheel fuses and all check out ok.

The flasher doesn't work with or without ignition on and the indicators / lock unlock work with flashing lights just fine.

I'm thinking switch, but would be great if someone else had similar issue?

Any help would be much appreciated !
Hi, what your saying is the hazards don't work + the indicators nor the flasher, it sounds like the relay ...
 
  #3  
Old 04-24-2019, 03:33 PM
DAV3's Avatar
Registered User
Thread Starter
Join Date: Apr 2019
Location: Warwickshire
Age: 32
Posts: 11
Rep Power: 0
DAV3 is an unknown quantity at this point
Hi, everything works (blinkers, unlock), except the hazards.

Do you know where the relay is?

Thanks.
 
  #4  
Old 04-25-2019, 06:11 AM
John Fiammetta's Avatar
Registered User
Join Date: Dec 2017
Location: switzerland
Age: 56
Posts: 73
Rep Power: 4
John Fiammetta will become famous soon enough
Has the centre console been out ?
Iam thinking switch , either disconnected or broken .I would look there 1st .
Most cars hazards share the same relays as the blinkers .
 
  #5  
Old 04-25-2019, 07:40 AM
BWings's Avatar
Registered User
Join Date: Mar 2018
Location: Arizona
Posts: 272
Rep Power: 12
BWings will become famous soon enough
Originally Posted by DAV3 View Post
Hi, everything works (blinkers, unlock), except the hazards.

Do you know where the relay is?

Thanks.
Hi Dav,

99.9% possibility it is a failed hazard switch on your console. There is no relay like in the old days. The hazard switch sends signal to the FRONT body control module. It, in turn, sends the command to the 4 corners signal bulbs. All of the old fashioned "blinkers" and "relays" are built into the digital circuitry in the FRONT body control module (not the rear body control module).

If the switch is not failed, then the F Body Control module has in part of its circuitry. The FBCM is replaceable only as a whole unit and has no internal plugin replaceable parts. No fuses either. The FBCM is protected by a simple 5a fuse, but if it failed, the module would not function and there would be far more not working than just hazards

The lower LH corner of this CAN topology is the focus of your issue.

Hope this help you:

 
  #6  
Old 04-25-2019, 11:11 AM
DAV3's Avatar
Registered User
Thread Starter
Join Date: Apr 2019
Location: Warwickshire
Age: 32
Posts: 11
Rep Power: 0
DAV3 is an unknown quantity at this point
Thumbs up

Yeah I think you're right, I haven't had the car that long and have never actually pressed the hazard switch since owning the vehicle.

Playing with the switch pack more, I notice that some of the centre buttons, suspension adjust etc, are very sticky and stay down when pressed.

So I dived in, stripped out the console and removed the switch pack (to acquire the part number), then deconstructed the switch pack and found brown sticky residue on the circuit board.

Looks like a previous owner has spilled some coffee/coke and done some damage. I tried cleaning it, but didn't seem to fix anything.

All other functions work on the switch pack, but the residue is over the hazard switch part of the board. Time to order a new switch pack and cross fingers it works.
 
  #7  
Old 04-25-2019, 11:28 AM
BWings's Avatar
Registered User
Join Date: Mar 2018
Location: Arizona
Posts: 272
Rep Power: 12
BWings will become famous soon enough
Ebay has had some in the past, but some sellers think they're better than new the way they're priced. Yours is an 06? Does it have the start button? That entire switch pack is a little more anyway.
 
  #8  
Old 04-25-2019, 12:26 PM
DAV3's Avatar
Registered User
Thread Starter
Join Date: Apr 2019
Location: Warwickshire
Age: 32
Posts: 11
Rep Power: 0
DAV3 is an unknown quantity at this point
Yes I've got the start button, but that is separate to the switch pack circuit assembly. And yes, ordered via eBay 😁 full console veneer with all console switches, was cheaper than just the switch lol

Can sell on the rest. It's the wrong switch part number suffix (no Aircon seats) but I really just care about the hazard to pass inspection. Once I know that's definitely the issue, then I'll order the right switch pack for my car.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MrOz
996
11
10-19-2018 04:15 PM
Talisman013
997 Turbo / GT2
14
10-25-2016 09:08 AM
mdurbahn
996
1
09-01-2010 12:56 AM
SecretAznSauce
996
1
02-01-2009 06:34 AM
RickyM3
Off Topic Forum
4
12-04-2007 09:47 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Hazard Warning Lights Not Working


Join 6SpeedOnline
Visit our Sponsors

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.